tocsin

PyPI/apache-airflow CVE-2026-41014: medium 4.3, EPSS 0.37%

The partitioned_dag_runs endpoints in the Airflow UI enforced only asset-level access control, not per-Dag authorization. An authenticated UI/API user with global Asset:read permission could enumerate

Action: Upgrade apache-airflow to 3.2.2 or later.

pip install apache-airflow==3.2.2

Affected

introducedfixedlast affected
3.2.03.2.2-

Fixed versions

3.2.2

Sources

CVE-2026-41014 · published · modified · JSON