tocsin

PyPI/apache-airflow CVE-2026-32690: low 3.7, EPSS 0.42%

Secrets in Variables saved as JSON dictionaries were not properly redacted - in case thee variables were retrieved by the user the secrets stored as nested fields were not masked.

Action: Upgrade apache-airflow to 3.2.0 or later.

pip install apache-airflow==3.2.0

Affected

introducedfixedlast affected
3.0.03.2.0-

Fixed versions

3.2.0

Sources

CVE-2026-32690 · published · modified · JSON