tocsin

PyPI/sentry-sdk CVE-2024-40647: low 2.5, EPSS 0.20%

Sentry's Python SDK unintentionally exposes environment variables to subprocesses

Action: Upgrade sentry-sdk to 1.45.1 or later.

pip install sentry-sdk==1.45.1
pip install sentry-sdk==2.8.0

Affected

introducedfixedlast affected
01.45.1-
2.0.0a12.8.0-

Fixed versions

1.45.12.8.0

Sources

CVE-2024-40647 · published · modified · JSON