PyPI/vllm CVE-2026-22807: high 8.8, EPSS 0.98%
vLLM affected by RCE via auto_map dynamic module loading during model initialization
Action: Upgrade vllm to 0.14.0 or later.
pip install vllm==0.14.0Affected
| introduced | fixed | last affected |
|---|---|---|
| 0.10.1 | 0.14.0 | - |
Fixed versions
| 0.14.0 |
Sources
- osv: PYSEC-2026-2010
- https://github.com/vllm-project/vllm/security/advisories/GHSA-2pc9-4j83-qjmr
- https://nvd.nist.gov/vuln/detail/CVE-2026-22807
- https://github.com/vllm-project/vllm/pull/32194
- https://github.com/vllm-project/vllm/commit/78d13ea9de4b1ce5e4d8a5af9738fea71fb024e5
- https://github.com/vllm-project/vllm
- https://github.com/vllm-project/vllm/releases/tag/v0.14.0
- https://pypi.org/project/vllm
- https://github.com/advisories/GHSA-2pc9-4j83-qjmr
CVE-2026-22807 · published · modified · JSON