PyPI/xgrammar CVE-2025-58446: high 7.5, EPSS 0.62%
xgrammar vulnerable to denial of service by huge enum grammar
Action: Upgrade xgrammar to 0.1.24 or later.
pip install xgrammar==0.1.24Affected
| introduced | fixed | last affected |
|---|---|---|
| 0.1.23 | 0.1.24 | - |
Fixed versions
| 0.1.24 |
Sources
- osv: PYSEC-2026-2055
- nvd: CVE-2025-58446
- https://github.com/mlc-ai/xgrammar/security/advisories/GHSA-9q5r-wfvf-rr7f
- https://github.com/mlc-ai/xgrammar/commit/ced69c3ad2f8f61b516cc278a342e7c644383e27
- https://github.com/mlc-ai/xgrammar
- https://pypi.org/project/xgrammar
- https://github.com/advisories/GHSA-9q5r-wfvf-rr7f
CVE-2025-58446 · published · modified · JSON