PyPI/apache-airflow CVE-2026-48892: medium 6.5, EPSS 0.66%
The Config API in Apache Airflow surfaced per-key secrets-backend overrides (environment variables like `AIRFLOW__SECRETS__BACKEND_KWARG__SECRET_ID` and `AIRFLOW__WORKERS__SECRETS_BACKEND_KWARG__SECRE
Action: Upgrade apache-airflow to 3.3.0 or later.
pip install apache-airflow==3.3.0Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 3.3.0 | - |
Fixed versions
| 3.3.0 |
Sources
- osv: PYSEC-2026-2087
- http://www.openwall.com/lists/oss-security/2026/07/07/4
- https://lists.apache.org/thread/pq5yy40079h6tzh3fxvw28dd8dbk72hk
- https://github.com/apache/airflow/pull/67622
- https://github.com/advisories/GHSA-9933-5rrp-mfwx
CVE-2026-48892 · published · modified · JSON