PyPI/daphne CVE-2026-44545: high 7.5, EPSS 0.33%
daphne before 4.2.2 did not pass maxFramePayloadSize or maxMessagePayloadSize to Autobahn's WebSocketServerFactory. Because Autobahn defaults both values to 0 (unlimited), an unauthenticated remote at
Action: Upgrade daphne to 4.2.2 or later.
pip install daphne==4.2.2Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 4.2.2 | - |
Fixed versions
| 4.2.2 |
Sources
- osv: PYSEC-2026-213
- https://github.com/django/daphne/blob/main/CHANGELOG.txt
- https://github.com/advisories/GHSA-rrc9-mx66-ffcm
CVE-2026-44545 · published · modified · JSON