tocsin

PyPI/flask-httpauth CVE-2026-34531: high 8.2, EPSS 0.34%

Flask-HTTPAuth provides Basic, Digest and Token HTTP authentication for Flask routes. Prior to version 4.8.1, in a situation where the client makes a request to a token protected resource without pass

Action: Upgrade flask-httpauth to 4.8.1 or later.

pip install flask-httpauth==4.8.1

Affected

introducedfixedlast affected
04.8.1-

Fixed versions

4.8.1

Sources

CVE-2026-34531 · published · modified · JSON