tocsin

PyPI/ironic CVE-2026-50589: high 7.5, EPSS 0.43%

In OpenStack Ironic 32 before 37.0.0, an unauthenticated malicious user could submit a crafted JSON string to some endpoints on the API or JSON-RPC service and effect a service crash.

Action: Upgrade ironic to 37.0.0 or later.

pip install ironic==37.0.0

Affected

introducedfixedlast affected
32.0.037.0.0-

Fixed versions

37.0.0

Sources

CVE-2026-50589 · published · modified · JSON