PyPI/glances CVE-2026-32596: high 7.5, EPSS 1.55%
Glances is an open-source system cross-platform monitoring tool. Prior to 4.5.2, Glances web server runs without authentication by default when started with `glances -w`, exposing REST API with sensit
Action: Upgrade glances to 4.5.2 or later.
pip install glances==4.5.2Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 4.5.2 | - |
Fixed versions
| 4.5.2 |
Sources
- osv: PYSEC-2026-2166
- https://github.com/nicolargo/glances/releases/tag/v4.5.2
- https://github.com/nicolargo/glances/commit/208d876118fea5758970f33fd7474908bd403d25
- https://github.com/nicolargo/glances/security/advisories/GHSA-wvxv-4j8q-4wjq
CVE-2026-32596 · published · modified · JSON