PyPI/glances CVE-2026-32610: high 8.1, EPSS 0.35%
Glances is an open-source system cross-platform monitoring tool. Prior to version 4.5.2, the Glances REST API web server ships with a default CORS configuration that sets `allow_origins=["*"]` combine
Action: Upgrade glances to 4.5.2 or later.
pip install glances==4.5.2Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 4.5.2 | - |
Fixed versions
| 4.5.2 |
Sources
- osv: PYSEC-2026-2169
- https://github.com/nicolargo/glances/releases/tag/v4.5.2
- https://github.com/nicolargo/glances/commit/4465169b71d93991f1e49740fe02428291099832
- https://github.com/nicolargo/glances/security/advisories/GHSA-9jfm-9rc6-2hfq
CVE-2026-32610 · published · modified · JSON