PyPI/glances CVE-2026-33641: high 7.8, EPSS 0.90%
Glances is an open-source system cross-platform monitoring tool. Prior to version 4.5.3, Glances supports dynamic configuration values in which substrings enclosed in backticks are executed as system
Action: Upgrade glances to 4.5.3 or later.
pip install glances==4.5.3Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 4.5.3 | - |
Fixed versions
| 4.5.3 |
Sources
- osv: PYSEC-2026-2174
- https://github.com/nicolargo/glances/releases/tag/v4.5.3
- https://github.com/nicolargo/glances/commit/358d76a225fc21a9f95d2c4d7e46fafe64a644c6
- https://github.com/nicolargo/glances/security/advisories/GHSA-qhj7-v7h7-q4c7
CVE-2026-33641 · published · modified · JSON