PyPI/gradio CVE-2026-49119: high 7.5, EPSS 0.69%
Gradio before 6.16.0 contain a path traversal vulnerability in the FileExplorer component's preprocess() method that allows unauthenticated attackers to escape the configured root directory by supplyi
Action: Upgrade gradio to 6.16.0 or later.
pip install gradio==6.16.0Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 6.16.0 | - |
Fixed versions
| 6.16.0 |
Sources
- osv: PYSEC-2026-2179
- nvd: CVE-2026-49119
- https://github.com/gradio-app/gradio/releases/tag/gradio%406.16.0
- https://github.com/gradio-app/gradio/commit/97d541f3d5fd05b2587a69ecc94b68fe5d2d7004
- https://github.com/gradio-app/gradio/pull/13437
- https://www.vulncheck.com/advisories/gradio-path-traversal-via-fileexplorer-preprocess
- https://github.com/advisories/GHSA-j36p-7w88-g82j
CVE-2026-49119 · published · modified · JSON