tocsin

PyPI/kafka-python CVE-2026-10143: high 7.5, EPSS 0.52%

kafka-python prior to 2.3.2 contains a denial-of-service vulnerability in SCRAM authentication handling that allows a malicious or machine-in-the-middle broker to freeze the client event loop by suppl

Action: Upgrade kafka-python to 2.3.2 or later.

pip install kafka-python==2.3.2

Affected

introducedfixedlast affected
02.3.2-

Fixed versions

2.3.2

Sources

CVE-2026-10143 · published · modified · JSON