PyPI/pi-heif CVE-2026-28231: critical 9.1, EPSS 0.70%
pillow_heif is a Python library for working with HEIF images and plugin for Pillow. Prior to version 1.3.0, an integer overflow in the encode path buffer validation of `_pillow_heif.c` allows an attac
Action: Upgrade pi-heif to 1.3.0 or later.
pip install pi-heif==1.3.0Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 1.3.0 | - |
Fixed versions
| 1.3.0 |
Sources
- osv: PYSEC-2026-2248
- https://github.com/bigcat88/pillow_heif/releases/tag/v1.3.0
- https://github.com/bigcat88/pillow_heif/commit/8305a15d3780c533b762578cbe987d27a2c59c7a
- https://github.com/bigcat88/pillow_heif/security/advisories/GHSA-5gjj-6r7v-ph3x
CVE-2026-28231 · published · modified · JSON