tocsin

PyPI/prefect CVE-2026-3514: high 7.5, EPSS 0.48%

In version 3.6.19 of prefecthq/prefect, an authentication bypass vulnerability exists due to the improper handling of URL path exemptions for health check probes. Specifically, the authentication midd

Action: Upgrade prefect to 3.6.22 or later.

pip install prefect==3.6.22

Affected

introducedfixedlast affected
03.6.22-

Fixed versions

3.6.22

Sources

CVE-2026-3514 · published · modified · JSON