PyPI/pyopenssl CVE-2026-27448: medium 5.3, EPSS 0.25%
pyOpenSSL is a Python wrapper around the OpenSSL library. Starting in version 0.14.0 and prior to version 26.0.0, if a user provided callback to `set_tlsext_servername_callback` raised an unhandled ex
Action: Upgrade pyopenssl to 26.0.0 or later.
pip install pyopenssl==26.0.0Affected
| introduced | fixed | last affected |
|---|---|---|
| 0.14 | 26.0.0 | - |
Fixed versions
| 26.0.0 |
Sources
- osv: PYSEC-2026-2268
- https://github.com/pyca/pyopenssl/blob/358cbf29c4e364c59930e53a270116249581eaa3/CHANGELOG.rst#L27
- https://github.com/pyca/pyopenssl/security/advisories/GHSA-vp96-hxj8-p424
- https://github.com/pyca/pyopenssl/commit/d41a814759a9fb49584ca8ab3f7295de49a85aa0
CVE-2026-27448 · published · modified · JSON