PyPI/crawl4ai CVE-2026-56258: high 8.1, EPSS 0.91%
Crawl4AI before 0.8.8 contains an arbitrary file write vulnerability in the screenshot and PDF endpoints that allows unauthenticated attackers to write files outside the intended directory via symlink
Action: Upgrade crawl4ai to 0.8.8 or later.
pip install crawl4ai==0.8.8Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 0.8.8 | - |
Fixed versions
| 0.8.8 |
Sources
- osv: PYSEC-2026-228
- nvd: CVE-2026-56258
- https://github.com/unclecode/crawl4ai/security/advisories/GHSA-7cx2-g3h9-382p
- https://www.vulncheck.com/advisories/crawl4ai-arbitrary-file-write-via-output-path-symlink-and-toctou
CVE-2026-56258 · published · modified · JSON