PyPI/starlette CVE-2026-48817: medium 5.3, EPSS 0.21%
Starlette is a lightweight ASGI framework/toolkit. In versions 1.0.1 and below, when dispatching a request, HTTPEndpoint selects the handler by lowercasing the HTTP method and looking it up as an attr
Action: Upgrade starlette to 1.1.0 or later.
pip install starlette==1.1.0Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 1.1.0 | - |
Fixed versions
| 1.1.0 |
Sources
- osv: PYSEC-2026-2280
- https://github.com/Kludex/starlette/releases/tag/1.1.0
- https://github.com/Kludex/starlette/security/advisories/GHSA-x746-7m8f-x49c
CVE-2026-48817 · published · modified · JSON