PyPI/transformers CVE-2026-1839: high 7.8, EPSS 0.38%
A vulnerability in the HuggingFace Transformers library, specifically in the `Trainer` class, allows for arbitrary code execution. The `_load_rng_state()` method in `src/transformers/trainer.py` at li
Action: Upgrade transformers to 5.0.0 or later.
pip install transformers==5.0.0Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 5.0.0 | - |
Fixed versions
| 5.0.0 |
Sources
- osv: PYSEC-2026-2288
- https://github.com/huggingface/transformers/commit/03c8082ba4594c9b8d6fe190ca9bed0e5f8ca396
- https://huntr.com/bounties/3c77bb97-e493-493d-9a88-c57f5c536485
- https://github.com/advisories/GHSA-69w3-r845-3855
CVE-2026-1839 · published · modified · JSON