PyPI/vllm CVE-2026-55574: high 7.5, EPSS 0.58%
vLLM is a high-throughput and memory-efficient inference and serving engine for LLMs. Prior to 0.24.0, the structured_outputs.regex API parameter passes a user-supplied regular expression string direc
Action: Upgrade vllm to 0.24.0 or later.
pip install vllm==0.24.0Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 0.24.0 | - |
Fixed versions
| 0.24.0 |
Sources
- osv: PYSEC-2026-2304
- https://github.com/vllm-project/vllm/security/advisories/GHSA-rwxx-mrjm-wc2m
- https://github.com/vllm-project/vllm/commit/2b3006076c5e9bc4cda9e03e3641388de3c5c286
- https://github.com/vllm-project/vllm/pull/45118
CVE-2026-55574 · published · modified · JSON