PyPI/weblate CVE-2026-24126: critical 9.1, EPSS 0.52%
Weblate is a web based localization tool. Prior to 5.16.0, the SSH management console did not validate the passed input while adding the SSH host key, which could lead to an argument injection to `ssh
Action: Upgrade weblate to 5.16 or later.
pip install weblate==5.16Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 5.16 | - |
Fixed versions
| 5.16 |
Sources
- osv: PYSEC-2026-2309
- https://github.com/WeblateOrg/weblate/pull/17722
- https://github.com/WeblateOrg/weblate/commit/78773cc141ce0a97900c11341e6cf856451395fd
- https://github.com/WeblateOrg/weblate/security/advisories/GHSA-33fm-6gp7-4p47
CVE-2026-24126 · published · modified · JSON