tocsin

PyPI/xgrammar CVE-2026-25048: high 7.5, EPSS 1.20%

xgrammar is an open-source library for efficient, flexible, and portable structured generation. Prior to version 0.1.32, the multi-level nested syntax caused a segmentation fault (core dumped). This i

Action: Upgrade xgrammar to 0.1.32 or later.

pip install xgrammar==0.1.32

Affected

introducedfixedlast affected
00.1.32-

Fixed versions

0.1.32

Sources

CVE-2026-25048 · published · modified · JSON