tocsin

PyPI/apache-airflow CVE-2026-40961: high 7.2, EPSS 0.65%

Apache Airflow: Authenticated users can bypass the `is_safe_url` check

Action: Upgrade apache-airflow to 3.2.2 or later.

pip install apache-airflow==3.2.2

Affected

introducedfixedlast affected
03.2.2-

Fixed versions

3.2.2

Sources

CVE-2026-40961 · published · modified · JSON