PyPI/cinder CVE-2022-47951: medium 5.7, EPSS 1.03%
OpenStack Cinder, glance, and Nova vulnerable to Path Traversal
Action: Upgrade cinder to 19.1.2 or later.
pip install cinder==19.1.2pip install cinder==20.0.2Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 19.1.2 | - |
| 20.0.0 | 20.0.2 | - |
Fixed versions
| 19.1.2 | 20.0.2 |
Sources
- osv: PYSEC-2026-2411
- https://nvd.nist.gov/vuln/detail/CVE-2022-47951
- https://launchpad.net/bugs/1996188
- https://lists.debian.org/debian-lts-announce/2023/01/msg00040.html
- https://lists.debian.org/debian-lts-announce/2023/01/msg00041.html
- https://lists.debian.org/debian-lts-announce/2023/01/msg00042.html
- https://security.openstack.org/ossa/OSSA-2023-002.html
- https://www.debian.org/security/2023/dsa-5336
- https://www.debian.org/security/2023/dsa-5337
- https://www.debian.org/security/2023/dsa-5338
- https://pypi.org/project/cinder
- https://github.com/advisories/GHSA-7h75-hwxx-qpgc
CVE-2022-47951 · published · modified · JSON