tocsin

PyPI/dbt-common CVE-2026-29790: medium 5.3, EPSS 0.28%

dbt-common's commonprefix() doesn't protect against path traversal

Action: Upgrade dbt-common to 1.34.2 or later.

pip install dbt-common==1.34.2
pip install dbt-common==1.37.3

Affected

introducedfixedlast affected
01.34.2-
1.35.01.37.3-

Fixed versions

1.34.21.37.3

Sources

CVE-2026-29790 · published · modified · JSON