PyPI/picklescan CVE-2025-71357: high 7.8, EPSS 0.39%
picklescan before 0.0.30 fails to detect malicious pickle files using idlelib.pyshell.ModifiedInterpreter.runcommand in reduce methods. Attackers can embed undetected code in pickle files that execute
Action: Upgrade picklescan to 0.0.30 or later.
pip install picklescan==0.0.30Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 0.0.30 | - |
Fixed versions
| 0.0.30 |
Sources
- osv: PYSEC-2026-246
- https://www.vulncheck.com/advisories/picklescan-arbitrary-code-execution-via-undetected-idlelib-pyshell-modifiedinterpreter-runcommand
- https://github.com/mmaitre314/picklescan/security/advisories/GHSA-j343-8v2j-ff7w
CVE-2025-71357 · published · modified · JSON