PyPI/glance CVE-2022-47951: medium 5.7, EPSS 1.03%
OpenStack Cinder, glance, and Nova vulnerable to Path Traversal
Action: Upgrade glance to 23.0.1 or later.
pip install glance==23.0.1pip install glance==24.1.1Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 23.0.1 | - |
| 24.0.0 | 24.1.1 | - |
Fixed versions
| 23.0.1 | 24.1.1 |
Sources
- osv: PYSEC-2026-2490
- https://nvd.nist.gov/vuln/detail/CVE-2022-47951
- https://launchpad.net/bugs/1996188
- https://lists.debian.org/debian-lts-announce/2023/01/msg00040.html
- https://lists.debian.org/debian-lts-announce/2023/01/msg00041.html
- https://lists.debian.org/debian-lts-announce/2023/01/msg00042.html
- https://security.openstack.org/ossa/OSSA-2023-002.html
- https://www.debian.org/security/2023/dsa-5336
- https://www.debian.org/security/2023/dsa-5337
- https://www.debian.org/security/2023/dsa-5338
- https://pypi.org/project/glance
- https://github.com/advisories/GHSA-7h75-hwxx-qpgc
CVE-2022-47951 · published · modified · JSON