tocsin

PyPI/ironic-python-agent CVE-2026-42997: high 7.7, EPSS 0.43%

OpenStack Ironic has an Incorrect Resource Transfer Between Spheres

Action: Upgrade ironic-python-agent to 26.1.6 or later.

pip install ironic-python-agent==26.1.6
pip install ironic-python-agent==29.0.5
pip install ironic-python-agent==32.0.1
pip install ironic-python-agent==35.0.1

Affected

introducedfixedlast affected
026.1.6-
27.0.029.0.5-
30.0.032.0.1-
33.0.035.0.1-

Fixed versions

26.1.629.0.532.0.135.0.1

Sources

CVE-2026-42997 · published · modified · JSON