PyPI/jupyterlab CVE-2026-40171: high 8.4, EPSS 0.48%
Jupyter Notebook Vulnerable to Authentication Token Theft via CommandLinker XSS
Action: Upgrade jupyterlab to 4.5.7 or later.
pip install jupyterlab==4.5.7Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 4.5.7 | - |
Fixed versions
| 4.5.7 |
Sources
- osv: PYSEC-2026-2538
- nvd: CVE-2026-40171
- https://github.com/jupyter/notebook/security/advisories/GHSA-rch3-82jr-f9w9
- https://github.com/jupyter/notebook
- https://jupyterlab.readthedocs.io/en/latest/user/commands.html#commands-in-markdown-output-and-files
- https://pypi.org/project/jupyterlab
- https://github.com/advisories/GHSA-rch3-82jr-f9w9
CVE-2026-40171 · published · modified · JSON