PyPI/langchain-classic CVE-2026-45134: high 7.1, EPSS 0.20%
LangSmith SDK: Public prompt pull deserializes untrusted manifests without trust boundary warning
Action: Upgrade langchain-classic to 1.0.7 or later.
pip install langchain-classic==1.0.7Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 1.0.7 | - |
Fixed versions
| 1.0.7 |
Sources
- osv: PYSEC-2026-2560
- https://github.com/langchain-ai/langsmith-sdk/security/advisories/GHSA-3644-q5cj-c5c7
- https://nvd.nist.gov/vuln/detail/CVE-2026-45134
- https://github.com/langchain-ai/langsmith-sdk
- https://pypi.org/project/langchain-classic
- https://github.com/advisories/GHSA-3644-q5cj-c5c7
CVE-2026-45134 · published · modified · JSON