tocsin

PyPI/litestar CVE-2024-32982: high 8.2, EPSS 0.72%

Litestar and Starlite vulnerable to Path Traversal

Action: Upgrade litestar to 2.6.4 or later.

pip install litestar==2.6.4
pip install litestar==2.7.2
pip install litestar==2.8.3

Affected

introducedfixedlast affected
2.0.02.6.4-
2.7.02.7.2-
2.8.02.8.3-

Fixed versions

2.6.42.7.22.8.3

Sources

CVE-2024-32982 · published · modified · JSON