PyPI/openexr CVE-2026-34543: high 7.5, EPSS 0.50%
OpenEXR: Heap information disclosure in PXR24 decompression via unchecked decompressed size (undo_pxr24_impl)
Action: Upgrade openexr to 3.4.8 or later.
pip install openexr==3.4.8Affected
| introduced | fixed | last affected |
|---|---|---|
| 3.2.0 | 3.4.8 | - |
Fixed versions
| 3.4.8 |
Sources
- osv: PYSEC-2026-2850
- nvd: CVE-2026-34543
- https://github.com/AcademySoftwareFoundation/openexr/security/advisories/GHSA-vc68-257w-m432
- https://github.com/AcademySoftwareFoundation/openexr/commit/5f6d0aaa9e43802917af7db90f181e88e083d3b8
- https://github.com/AcademySoftwareFoundation/openexr
- https://github.com/AcademySoftwareFoundation/openexr/releases/tag/v3.4.8
- https://pypi.org/project/openexr
- https://github.com/advisories/GHSA-vc68-257w-m432
CVE-2026-34543 · published · modified · JSON