PyPI/pip CVE-2026-6357: medium 5.3, EPSS 0.14%
pip Vulnerable to Inclusion of Functionality from Untrusted Control Sphere
Action: Upgrade pip to 26.1 or later.
pip install pip==26.1Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 26.1 | - |
Fixed versions
| 26.1 |
Sources
- osv: PYSEC-2026-2876
- nvd: CVE-2026-6357
- https://github.com/pypa/pip/pull/13923
- https://github.com/pypa/pip/commit/b369bfc96cc524e00c267e1693290e6599c36bad
- https://github.com/pypa/pip
- https://ichard26.github.io/blog/2026/04/whats-new-in-pip-26.1/#security-fixes
- http://www.openwall.com/lists/oss-security/2026/04/27/7
- https://pypi.org/project/pip
- https://github.com/advisories/GHSA-jp4c-xjxw-mgf9
CVE-2026-6357 · published · modified · JSON