PyPI/pymonocypher CVE-2026-53720: medium 5.1, EPSS 0.18%
pymonocypher: Potential heap buffer overflow on nb_blocks in argon2i_32 when provided buffer is too small
Action: Upgrade pymonocypher to 4.0.2.8 or later.
pip install pymonocypher==4.0.2.8Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 4.0.2.8 | - |
Fixed versions
| 4.0.2.8 |
Sources
- osv: PYSEC-2026-3000
- nvd: CVE-2026-53720
- https://github.com/jetperch/pymonocypher/security/advisories/GHSA-8f95-v3jq-cj86
- https://github.com/jetperch/pymonocypher/commit/90ff5b13b13b5673c372e188f482d8c172e6ab86
- https://github.com/jetperch/pymonocypher
- https://pypi.org/project/pymonocypher
- https://github.com/advisories/GHSA-8f95-v3jq-cj86
CVE-2026-53720 · published · modified · JSON