PyPI/praisonai CVE-2026-57112: high 8.3, EPSS 0.22%
PraisonAI ToolsMCPServer legacy SSE transport accepts attacker Host/Origin and exposes registered tools
Action: Upgrade praisonai to 4.6.59 or later.
pip install praisonai==4.6.59Affected
| introduced | fixed | last affected |
|---|---|---|
| 3.10.0 | 4.6.59 | - |
Fixed versions
| 4.6.59 |
Sources
- osv: PYSEC-2026-3521
- https://github.com/MervinPraison/PraisonAI/security/advisories/GHSA-vmf9-xx9w-86wx
- https://github.com/MervinPraison/PraisonAI
- https://pypi.org/project/praisonai
- https://github.com/advisories/GHSA-vmf9-xx9w-86wx
- https://nvd.nist.gov/vuln/detail/CVE-2026-57112
CVE-2026-57112 · published · modified · JSON