tocsin

PyPI/internetarchive CVE-2025-58438: critical 9.4, EPSS 1.59%

internetarchive Vulnerable to Directory Traversal in File.download()

Action: Upgrade internetarchive to 5.5.1 or later.

pip install internetarchive==5.5.1

Affected

introducedfixedlast affected
05.5.1-

Fixed versions

5.5.1

Sources

CVE-2025-58438 · published · modified · JSON