PyPI/apache-airflow CVE-2026-68968: high 7.5, EPSS 0.42%
Apache Airflow's Backfill API authorized a request against a Dag id supplied by the caller whenever the `backfill_id` path segment failed to parse. The authorization dependency parsed it with `int()`
Action: Upgrade apache-airflow to 3.3.1 or later.
pip install apache-airflow==3.3.1Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 3.3.1 | - |
Fixed versions
| 3.3.1 |
Sources
- osv: PYSEC-2026-3710
- https://github.com/apache/airflow/pull/70889
- http://www.openwall.com/lists/oss-security/2026/08/12/12
- https://lists.apache.org/thread/f9zmw6xs5b4syhwzbl6fsxm4kf2632ol
- https://github.com/advisories/GHSA-j4jc-cq9h-xrhr
CVE-2026-68968 · published · modified · JSON