PyPI/pip CVE-2026-13346: medium 6.5, EPSS 0.29%
pip would incorrectly handle doubly-encoded package URLs from indexes allowing for files to be installed to arbitrary locations on disk even when installing wheels.
Action: Upgrade pip to 26.2 or later.
pip install pip==26.2Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 26.2 | - |
Fixed versions
| 26.2 |
Sources
- osv: PYSEC-2026-3721
- http://www.openwall.com/lists/oss-security/2026/07/29/7
- https://mail.python.org/archives/list/security-announce@python.org/thread/L2BNQGGVQCEV7DROOORQ7WFKKFF2OOQX/
- https://github.com/pypa/pip/pull/14110
- https://github.com/advisories/GHSA-qwm4-qh6w-59xr
CVE-2026-13346 · published · modified · JSON