tocsin

PyPI/nltk CVE-2026-63312: high 7.5, EPSS 0.65%

NLTK before 3.10.0 contains an arbitrary local file read vulnerability in StreamBackedCorpusView that bypasses pathsec.ENFORCE by calling builtins.open() directly instead of pathsec.open(). Attackers

Action: Upgrade nltk to 3.10.0 or later.

pip install nltk==3.10.0

Affected

introducedfixedlast affected
03.10.0-

Fixed versions

3.10.0

Sources

CVE-2026-63312 · published · modified · JSON