PyPI/nltk CVE-2026-70626: medium 6.2, EPSS 0.20%
NLTK versions before 3.9.4 contain a symlink escape vulnerability in CorpusReader.open() that allows local attackers to read arbitrary files outside the corpus root. The vulnerability exists because p
Action: Upgrade nltk to 3.9.4 or later.
pip install nltk==3.9.4Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 3.9.4 | - |
Fixed versions
| 3.9.4 |
Sources
- osv: PYSEC-2026-3732
- nvd: CVE-2026-70626
- https://www.vulncheck.com/advisories/nltk-before-symlink-escape-via-corpusreader
- https://github.com/nltk/nltk/security/advisories/GHSA-r6gq-whwq-mvg9
CVE-2026-70626 · published · modified · JSON