PyPI/nltk CVE-2026-79674: high 8.2, EPSS 0.39%
NLTK versions before 3.10.3 contain a path sandbox bypass vulnerability in corpus-reader constructors that allows attackers to read files outside the intended data root. Attackers can supply arbitrary
Action: Upgrade nltk to 3.10.3 or later.
pip install nltk==3.10.3Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 3.10.3 | - |
Fixed versions
| 3.10.3 |
Sources
- osv: PYSEC-2026-3736
- nvd: CVE-2026-79674
- https://www.vulncheck.com/advisories/nltk-path-traversal-via-corpus-reader-constructors
- https://github.com/nltk/nltk/security/advisories/GHSA-3gq4-3j92-5w49
CVE-2026-79674 · published · modified · JSON