PyPI/nltk CVE-2026-81722: unknown, EPSS 0.52%
nltk PorterStemmer in versions <= 3.10.2 (fixed in 3.10.3) contains an inefficient-algorithmic-complexity denial of service in PorterStemmer.stem(). The _is_consonant() helper walks backward over the
Action: Upgrade nltk to 3.10.3 or later.
pip install nltk==3.10.3Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 3.10.3 | - |
Fixed versions
| 3.10.3 |
Sources
- osv: PYSEC-2026-3738
- https://www.vulncheck.com/advisories/nltk-porterstemmer-before-3.10.3-quadratic-time-dos
- https://github.com/nltk/nltk/security/advisories/GHSA-ww6m-cw3f-q94g
CVE-2026-81722 · published · modified · JSON