PyPI/nltk CVE-2026-81727: high 7.1, EPSS 0.19%
NLTK versions before 3.10.3 contain a filesystem containment bypass vulnerability in the Downloader.download and Downloader.incr_download methods that allows attackers to overwrite files outside the i
Action: Upgrade nltk to 3.10.3 or later.
pip install nltk==3.10.3Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 3.10.3 | - |
Fixed versions
| 3.10.3 |
Sources
- osv: PYSEC-2026-3741
- nvd: CVE-2026-81727
- https://www.vulncheck.com/advisories/nltk-before-3.10.3-hardlink-file-overwrite-via-downloader
- https://github.com/nltk/nltk/security/advisories/GHSA-f794-5jv7-7672
CVE-2026-81727 · published · modified · JSON