PyPI/openssl-encrypt CVE-2026-74880: critical 9.8, EPSS 0.56%
openssl_encrypt versions before 1.4.0 accept refresh tokens as URL query parameters in keyserver and telemetry server routes. Attackers can extract tokens from server logs, proxy logs, browser history
Action: Upgrade openssl-encrypt to 1.4.0 or later.
pip install openssl-encrypt==1.4.0Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 1.4.0 | - |
Fixed versions
| 1.4.0 |
Sources
- osv: PYSEC-2026-3759
- nvd: CVE-2026-74880
- https://github.com/jahlives/openssl_encrypt/security/advisories/GHSA-4rh7-jwg9-m28m
- https://www.vulncheck.com/advisories/openssl-encrypt-before-token-leakage-via-query-parameters
CVE-2026-74880 · published · modified · JSON