PyPI/gitpython CVE-2026-76221: high 8.8, EPSS 0.48%
GitPython before 3.1.58 contains a config-name injection vulnerability in the option-name validator that allows attackers to forge arbitrary git-config directives by injecting equals signs, hash symbo
Action: Upgrade gitpython to 3.1.58 or later.
pip install gitpython==3.1.58Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 3.1.58 | - |
Fixed versions
| 3.1.58 |
Sources
- osv: PYSEC-2026-3783
- nvd: CVE-2026-76221
- https://www.vulncheck.com/advisories/gitpython-before-config-injection-via-option-name
- https://github.com/gitpython-developers/GitPython/security/advisories/GHSA-jm78-9fvv-mhgr
CVE-2026-76221 · published · modified · JSON