tocsin

PyPI/gitpython CVE-2026-78675: high 7.8, EPSS 0.18%

GitPython before 3.1.59 fails to disable merge_includes when parsing .gitmodules, allowing attackers to disclose local file content by including arbitrary file paths via [include] directives. Attacker

Action: Upgrade gitpython to 3.1.59 or later.

pip install gitpython==3.1.59

Affected

introducedfixedlast affected
03.1.59-

Fixed versions

3.1.59

Sources

CVE-2026-78675 · published · modified · JSON