tocsin

PyPI/gitpython CVE-2026-78676: unknown, EPSS 0.78%

GitPython before 3.1.59 fails to safely re-serialize multi-line git-config values during write operations, corrupting dormant quoted values into injected directives like core.hooksPath. Attackers can

Action: Upgrade gitpython to 3.1.59 or later.

pip install gitpython==3.1.59

Affected

introducedfixedlast affected
03.1.59-

Fixed versions

3.1.59

Sources

CVE-2026-78676 · published · modified · JSON