tocsin

PyPI/nltk CVE-2026-71514: low 3.3, EPSS 0.17%

NLTK 3.9.4 through 3.10.2 contains a path traversal vulnerability in CrubadanCorpusReader. _load_lang_ngrams joins the corpus root with crubadan_code, the column-0 value read from the corpus table.txt

Action: Upgrade nltk to 3.10.3 or later.

pip install nltk==3.10.3

Affected

introducedfixedlast affected
3.9.43.10.3-

Fixed versions

3.10.3

Sources

CVE-2026-71514 · published · modified · JSON