PyPI/gitpython CVE-2026-73619: medium 6.5, EPSS 0.41%
GitPython before 3.1.57 contains an incomplete denylist in the unsafe_git_archive_options guard that omits --add-file and --add-virtual-file options. Attackers can supply these options to Repo.archive
Action: Upgrade gitpython to 3.1.57 or later.
pip install gitpython==3.1.57Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 3.1.57 | - |
Fixed versions
| 3.1.57 |
Sources
- osv: PYSEC-2026-3948
- nvd: CVE-2026-73619
- https://www.vulncheck.com/advisories/gitpython-before-arbitrary-file-read-via-repo-archive
- https://github.com/gitpython-developers/GitPython/security/advisories/GHSA-539m-9xh6-q6rr
CVE-2026-73619 · published · modified · JSON